Calling all Americans (and Australians/NZ/Pacific Rim…)

For about 3 weeks now researchers in the US have had their default Ensembl go to our US west mirror (uswest.ensembl.org) automatically – if you just go to www.ensembl.org you brower gets automatically redirected. The US joined Japan and Canada who we switched in late 2009.

From our perspective, this is all working fine; the usage of uswest has gone up, and IP tracking on that shows far more US IP addresses (so the redirect is working fine!). We get some 3,000 odd visits a day, with some 50,000 pages delivered from our uswest site – about 20% of our total hits. Brilliant.

What is slightly more surprising is that we’re not getting any queries on this. Given the usage, we think this means the default browser, content and other functionality must be working well (or Americans are very shy about complaining… but that doesn’t sound like a good description of all Americans…). But we’d also like to hear from American users – have you noticed ensembl “go faster?”. Are there any glitches?

Another issue we are unclear about is whether we should automatically shift other users on the Pacific Rim to automatically go to uswest – in terms of usage, the biggest country would be Australia, but New Zealand, Phillipines and other Pacific Rim countries would also be candidates. It’s quite hard for us to assess whether our Europe (Cambridge UK) based servers or US west servers are best for this – both latency and throughput changes on different routes, and the time zone shift makes things complex to assess systematically in an easy way.

So – feedback welcome – either on this post or by email to our helpdesk about what your experience is, either from the US or from the Pacific Rim.

Comments are closed.