Update to Perl and BioPerl in Ensembl

From Ensembl 93 onwards, we plan to recommend newer versions of Perl (5.14- 5.26) and BioPerl (1.6.924) when using the Ensembl Perl API. This may affect pipelines which employ the Ensembl Perl API, since we will no longer actively support older versions of Perl and BioPerl.

At Ensembl, we’ve been using Perl since the project was born all the way back in 1999 (last century!). We are continuously looking at the latest versions of Perl and BioPerl, testing them against the Ensembl data and APIs, and deciding which versions we are able to officially support. The most up-to-date versions of Perl and BioPerl that we currently support are Perl 5.14 and BioPerl 1.6.1, so we thought it was high-time that we moved to support more recent versions.

Following the most recent rounds of testing, we are now able to support more up-to-date versions of Perl and BioPerl. From Ensembl 93 onwards, we will recommend Perl 5.14 – 5.26 and BioPerl 1.6.924.

However, this means that some older versions will no longer be officially supported. We will no longer support Perl 5.10 (or any earlier versions), which may affect pipelines employing older Perl versions. Of course, there is no reason that you have to change as long as everything still works but we have stopped testing these older versions of Perl and BioPerl and therefore can’t absolutely guarantee functionality and provide support.

We hope that this broadening of support for more recent versions of Perl and BioPerl does not disrupt currently employed pipelines, but if you do have any questions, please do not hesitate to get in touch with the Ensembl helpdesk.

 

 

Leave a Reply

Your email address will not be published. Required fields are marked *